import Foundation
let pattern = ##"(lang=)[^&#]*"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2
http://winner.com/?page=home&lang=es&lang=en#hash
http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash
http://winner.com/test.html#HashValue?lang=QueryValue
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1en"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)