const regex = /(lang=)[^&#]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(lang=)[^&#]*', 'g')
const str = `http://winner.com/?page=home&lang=es&lang=en&lang=es&bas=2
http://winner.com/?page=home&lang=es&lang=en#hash
http://winner.com/?page=home&lang=es&lang=en&lang=es&base=2#hash
http://winner.com/test.html#HashValue?lang=QueryValue`;
const subst = `$1en`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);