using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]*?src\s*=\s*[""']?([^'"" >]+?)[ '""][^>]*?>";
string input = @"Hello World..
<img src=""a1.png"" width=""100"" height=""50"" />
<img src=""a1.png"" width=""100"" height=""50"">
<img style=""width:100px;height:50px"" src=""a1.png"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}