const regex = /<img[^>]*?src\s*=\s*[""']?([^'"" >]+?)[ '""][^>]*?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img[^>]*?src\\s*=\\s*[""\']?([^\'"" >]+?)[ \'""][^>]*?>', 'g')
const str = `Hello World..
<img src="a1.png" width="100" height="50" />
<img src="a1.png" width="100" height="50">
<img style="width:100px;height:50px" src="a1.png" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}