// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img[^>]*?src\s*=\s*[""']?([^'"" >]+?)[ '""][^>]*?>"#).unwrap();
let string = "Hello World..
<img src=\"a1.png\" width=\"100\" height=\"50\" />
<img src=\"a1.png\" width=\"100\" height=\"50\">
<img style=\"width:100px;height:50px\" src=\"a1.png\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}