$re = '/<img[^>]*?src\s*=\s*[""\']?([^\'"" >]+?)[ \'""][^>]*?>/';
$str = 'Hello World..
<img src="a1.png" width="100" height="50" />
<img src="a1.png" width="100" height="50">
<img style="width:100px;height:50px" src="a1.png" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);