import re
regex = re.compile(r"<img[^>]*?src\s*=\s*[\"\"']?([^'\"\" >]+?)[ '\"\"][^>]*?>")
test_str = ("Hello World..\n"
"<img src=\"a1.png\" width=\"100\" height=\"50\" />\n"
"<img src=\"a1.png\" width=\"100\" height=\"50\">\n"
"<img style=\"width:100px;height:50px\" src=\"a1.png\" />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")