import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]*?src\\s*=\\s*[\"\"']?([^'\"\" >]+?)[ '\"\"][^>]*?>";
final String string = "Hello World..\n"
+ "<img src=\"a1.png\" width=\"100\" height=\"50\" />\n"
+ "<img src=\"a1.png\" width=\"100\" height=\"50\">\n"
+ "<img style=\"width:100px;height:50px\" src=\"a1.png\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}