use strict;
my $str = 'Hello World..
<img src="a1.png" width="100" height="50" />
<img src="a1.png" width="100" height="50">
<img style="width:100px;height:50px" src="a1.png" />';
my $regex = qr/<img[^>]*?src\s*=\s*[""']?([^'"" >]+?)[ '""][^>]*?>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}