package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img[^>]*?src\s*=\s*[""']?([^'"" >]+?)[ '""][^>]*?>`)
var str = `Hello World..
<img src="a1.png" width="100" height="50" />
<img src="a1.png" width="100" height="50">
<img style="width:100px;height:50px" src="a1.png" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}