re = /<img[^>]*?src\s*=\s*[""']?([^'"" >]+?)[ '""][^>]*?>/
str = 'Hello World..
<img src="a1.png" width="100" height="50" />
<img src="a1.png" width="100" height="50">
<img style="width:100px;height:50px" src="a1.png" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end