# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/stringBuilder\.append\("(.)"\)/stringBuilder.append('$1')/gm;t' <<< "stringBuilder.append(\"x\")
sysout.println(\"x\" + 2)
sysout.println('x' + 2)"