import re
regex = re.compile(r"stringBuilder\.append\(\"(.)\"\)", flags=re.MULTILINE)
test_str = ("stringBuilder.append(\"x\") \n"
"sysout.println(\"x\" + 2)\n"
"sysout.println('x' + 2)")
subst = "stringBuilder.append('$1')"
result = regex.sub(subst, test_str)
if result:
print(result)