$re = '/stringBuilder\.append\("(.)"\)/m';
$str = 'stringBuilder.append("x")
sysout.println("x" + 2)
sysout.println(\'x\' + 2)';
$subst = "stringBuilder.append('$1')";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;