// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)stringBuilder\.append\("(.)"\)"#).unwrap();
let string = "stringBuilder.append(\"x\")
sysout.println(\"x\" + 2)
sysout.println('x' + 2)";
let substitution = "stringBuilder.append('$1')";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}