const regex = /stringBuilder\.append\("(.)"\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('stringBuilder\\.append\\("(.)"\\)', 'gm')
const str = `stringBuilder.append("x")
sysout.println("x" + 2)
sysout.println('x' + 2)`;
const subst = `stringBuilder.append('$1')`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);