#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)stringBuilder\.append\("(.)"\)"
Local $sString = "stringBuilder.append("x") " & @CRLF & _
"sysout.println("x" + 2)" & @CRLF & _
"sysout.println('x' + 2)"
Local $sSubst = "stringBuilder.append('$1')"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)