import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "stringBuilder\\.append\\(\"(.)\"\\)";
final String string = "stringBuilder.append(\"x\") \n"
+ "sysout.println(\"x\" + 2)\n"
+ "sysout.println('x' + 2)";
final String subst = "stringBuilder.append('$1')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}