use strict;
my $str = 'stringBuilder.append("x")
sysout.println("x" + 2)
sysout.println(\'x\' + 2)';
my $regex = qr/stringBuilder\.append\("(.)"\)/mp;
my $subst = 'stringBuilder.append(\'$1\')';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";