# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*/\1\2/gm;t' <<< "1234 Alpha Bee"