using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*";
string substitution = @"\1\2";
string input = @"1234 Alpha Bee";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}