#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*"
Local $sString = "1234 Alpha Bee"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)