// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*").unwrap();
let string = "1234 Alpha Bee";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}