$re = '/(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*/m';
$str = '1234 Alpha Bee';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;