use strict;
my $str = '1234 Alpha Bee';
my $regex = qr/(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";