package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*`)
var str = `1234 Alpha Bee`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}