const regex = new RegExp('(?i)\\b([1-9][0-9]{3} ?[a-z])[a-z]* +([a-z])[a-z]*', 'gm')
const str = `1234 Alpha Bee`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);