package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)public ([^ ]++) ([a-z])([^ ]*+) { get; set; }`)
var str = `public string symbol { get; set; }
public string pair { get; set; }
public string contractType { get; set; }
public string status { get; set; }
public string baseAsset { get; set; }
public string quoteAsset { get; set; }
public string marginAsset { get; set; }`
var substitution = "[JsonPropertyName("$2$3")]\npublic $1 \U$2\E$3 { get; set; }"
fmt.Println(re.ReplaceAllString(str, substitution))
}