import re
regex = re.compile(r"public ([^ ]++) ([a-z])([^ ]*+) { get; set; }", flags=re.MULTILINE)
test_str = ("public string symbol { get; set; }\n"
"public string pair { get; set; }\n"
"public string contractType { get; set; }\n"
"public string status { get; set; }\n"
"public string baseAsset { get; set; }\n"
"public string quoteAsset { get; set; }\n"
"public string marginAsset { get; set; }")
subst = "[JsonPropertyName(\"$2$3\")]\\npublic $1 \\U$2\\E$3 { get; set; }"
result = regex.sub(subst, test_str)
if result:
print(result)