$re = '/public ([^ ]++) ([a-z])([^ ]*+) { get; set; }/m';
$str = 'public string symbol { get; set; }
public string pair { get; set; }
public string contractType { get; set; }
public string status { get; set; }
public string baseAsset { get; set; }
public string quoteAsset { get; set; }
public string marginAsset { get; set; }';
$subst = "[JsonPropertyName(\"$2$3\")]\npublic $1 \U$2\E$3 { get; set; }";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;