// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)public ([^ ]++) ([a-z])([^ ]*+) { get; set; }").unwrap();
let string = "public string symbol { get; set; }
public string pair { get; set; }
public string contractType { get; set; }
public string status { get; set; }
public string baseAsset { get; set; }
public string quoteAsset { get; set; }
public string marginAsset { get; set; }";
let substitution = "[JsonPropertyName(\"$2$3\")]\\npublic $1 \\U$2\\E$3 { get; set; }";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}