const regex = /public ([^ ]++) ([a-z])([^ ]*+) { get; set; }/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('public ([^ ]++) ([a-z])([^ ]*+) { get; set; }', 'gm')
const str = `public string symbol { get; set; }
public string pair { get; set; }
public string contractType { get; set; }
public string status { get; set; }
public string baseAsset { get; set; }
public string quoteAsset { get; set; }
public string marginAsset { get; set; }`;
const subst = `[JsonPropertyName("$2$3")]\npublic $1 \U$2\E$3 { get; set; }`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);