use strict;
my $str = 'public string symbol { get; set; }
public string pair { get; set; }
public string contractType { get; set; }
public string status { get; set; }
public string baseAsset { get; set; }
public string quoteAsset { get; set; }
public string marginAsset { get; set; }';
my $regex = qr/public ([^ ]++) ([a-z])([^ ]*+) { get; set; }/mp;
my $subst = '[JsonPropertyName("$2$3")]\\npublic $1 \\U$2\\E$3 { get; set; }';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";