import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public ([^ ]++) ([a-z])([^ ]*+) \\{ get; set; \\}";
final String string = "public string symbol { get; set; }\n"
+ "public string pair { get; set; }\n"
+ "public string contractType { get; set; }\n"
+ "public string status { get; set; }\n"
+ "public string baseAsset { get; set; }\n"
+ "public string quoteAsset { get; set; }\n"
+ "public string marginAsset { get; set; }";
final String subst = "[JsonPropertyName(\"$2$3\")]\\npublic $1 \\U$2\\E$3 { get; set; }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}