# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*_en)(.*)$/\1_fr/gm;t' <<< "value_1_en
value_1
value_2_en
value_2
value_3_en
value_3"