import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*_en)(.*)$";
final String string = "value_1_en\n"
+ "value_1\n"
+ "value_2_en\n"
+ "value_2\n"
+ "value_3_en\n"
+ "value_3";
final String subst = "\\1_fr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}