import re
regex = re.compile(r"^(?!.*_en)(.*)$", flags=re.MULTILINE)
test_str = ("value_1_en\n"
"value_1\n"
"value_2_en\n"
"value_2\n"
"value_3_en\n"
"value_3")
subst = "\\1_fr"
result = regex.sub(subst, test_str)
if result:
print(result)