using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*_en)(.*)$";
string substitution = @"\1_fr";
string input = @"value_1_en
value_1
value_2_en
value_2
value_3_en
value_3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}