import Foundation
let pattern = #"^(?!.*_en)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
value_1_en
value_1
value_2_en
value_2
value_3_en
value_3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1_fr"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)