#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*_en)(.*)$"
Local $sString = "value_1_en" & @CRLF & _
"value_1" & @CRLF & _
"value_2_en" & @CRLF & _
"value_2" & @CRLF & _
"value_3_en" & @CRLF & _
"value_3"
Local $sSubst = "\1_fr"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)