const regex = /^(?!.*_en)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*_en)(.*)$', 'gm')
const str = `value_1_en
value_1
value_2_en
value_2
value_3_en
value_3`;
const subst = `\1_fr`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);