use strict;
my $str = 'value_1_en
value_1
value_2_en
value_2
value_3_en
value_3';
my $regex = qr/^(?!.*_en)(.*)$/mp;
my $subst = '\\1_fr';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";