# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\$\$.*?)lo(.*?\$\$)/\15\2/gm;t' <<< "some random text $$ hello world $$ some more stuff"