import re
regex = re.compile(r"(\$\$.*?)lo(.*?\$\$)", flags=re.MULTILINE)
test_str = "some random text $$ hello world $$ some more stuff"
subst = "\\15\\2"
result = regex.sub(subst, test_str)
if result:
print(result)