import Foundation
let pattern = #"(\$\$.*?)lo(.*?\$\$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"some random text $$ hello world $$ some more stuff"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\15\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)