const regex = /(\$\$.*?)lo(.*?\$\$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\$\\$.*?)lo(.*?\\$\\$)', 'gm')
const str = `some random text \$\$ hello world \$\$ some more stuff`;
const subst = `\15\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);