use strict;
my $str = 'some random text $$ hello world $$ some more stuff';
my $regex = qr/(\$\$.*?)lo(.*?\$\$)/mp;
my $subst = '\\15\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";