using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\$\$.*?)lo(.*?\$\$)";
string substitution = @"\15\2";
string input = @"some random text $$ hello world $$ some more stuff";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}