$re = '/(\$\$.*?)lo(.*?\$\$)/m';
$str = 'some random text $$ hello world $$ some more stuff';
$subst = "\15\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;