re = /(\$\$.*?)lo(.*?\$\$)/m
str = 'some random text $$ hello world $$ some more stuff'
subst = '\\15\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result